lunes, 23 de marzo de 2009

Fórmulas y Funciones (I)

Esta unidad es la unidad una de las más importantes del curso, pues en su comprensión y manejo está la base de Excel. Qué es una hoja de cálculo sino una base de datos que utilizamos con una serie de fórmulas para evitar tener que recalcular por cada cambio que hacemos. Por eso esta unidad es fundamental para el desarrollo del curso y la buena utilización de Excel.
Vamos a profundizar en el manejo de funciones ya definidas por Excel 2007 para agilizar la creación de hojas de cálculo, estudiando la sintaxis de éstas así como el uso del asistente para funciones, herramienta muy útil cuando no conocemos muy bien las funciones existentes o la sintaxis de éstas.

Introducir Fórmulas y Funciones
Una función es una fórmula predefinida por Excel 2007 (o por el usuario) que opera con uno o más valores y devuelve un resultado que aparecerá directamente en la celda o será utilizado para calcular la fórmula que la contiene.
La sintaxis de cualquier función es:
nombre_función(argumento1;argumento2;...;argumentoN)
Siguen las siguientes reglas:
- Si la función va al comienzo de una fórmula debe empezar por el signo =.
- Los argumentos o valores de entrada van siempre entre paréntesis. No dejes espacios antes o después de cada paréntesis.
- Los argumentos pueden ser valores constantes (número o texto), fórmulas o funciones.
- Los argumentos deben de separarse por un punto y coma ;.
Ejemplo: =SUMA(A1:C8)
Tenemos la función SUMA() que devuelve como resultado la suma de sus argumentos. El operador ":" nos identifica un rango de celdas, así A1:C8 indica todas las celdas incluidas entre la celda A1 y la C8, así la función anterior sería equivalente a:
=A1+A2+A3+A4+A5+A6+A7+A8+B1+B2+B3+B4+B5+B6+B7+B8+C1+C2+C3+C4+C5+C6+C7+C8
En este ejemplo se puede apreciar la ventaja de utilizar la función.
Las fórmulas pueden contener más de una función, y pueden aparecer funciones anidadas dentro de la fórmula.
Ejemplo: =SUMA(A1:B4)/SUMA(C1:D4)
Existen muchos tipos de funciones dependiendo del tipo de operación o cálculo que realizan. Así hay funciones matemáticas y trigonométricas, estadísticas, financieras, de texto, de fecha y hora, lógicas, de base de datos, de búsqueda y referencia y de información.
Para introducir una fórmula debe escribirse en una celda cualquiera tal cual introducimos cualquier texto, precedida siempre del signo =.
Si quieres conocer más sobre los operadores más utilizados y las precedencias de los operadores visita nuestro básico .



Una función como cualquier dato se puede escribir directamente en la celda si conocemos su sintaxis, pero Excel 2007 dispone de una ayuda o asistente para utilizarlas, así nos resultará más fácil trabajar con ellas.
Si queremos introducir una función en una celda:
Situarse en la celda donde queremos introducir la función.
Hacer clic en la pestaña Fórmulas.
Elegir la opción Insertar función.
O bien, hacer clic sobre el botón de la barra de fórmulas.
Aparecerá el siguiente cuadro de diálogo Insertar función:
Excel 2007 nos permite buscar la función que necesitamos escribiendo una breve descripción de la función necesitada en el recuadro Buscar una función: y a continuación hacer clic sobre el botón , de esta forma no es necesario conocer cada una de las funciones que incorpora Excel ya que el nos mostrará en el cuadro de lista Seleccionar una función: las funciones que tienen que ver con la descripción escrita.
Para que la lista de funciones no sea tan extensa podemos seleccionar previamente una categoría del cuadro combinado O seleccionar una categoría:, esto hará que en el cuadro de lista sólo aparezcan las funciones de la categoría elegida y reduzca por lo tanto la lista. Si no estamos muy seguros de la categoría podemos elegir Todas.
En el cuadro de lista Seleccionar una función: hay que elegir la función que deseamos haciendo clic sobre ésta.
Observa como conforme seleccionamos una función, en la parte inferior nos aparecen los distintos argumentos y una breve descripción de ésta. También disponemos de un enlace Ayuda sobre esta función para obtener una descripción más completa de dicha función.
A final, hacer clic sobre el botón Aceptar.
crear una tabla de datos.


Para crear una tabla de datos tenemos que hacer clic en la pestaña Crear para visualizar sus opciones. En el marco Tablas podremos seleccionar estas opciones:

Crear Tabla

El botón Tabla abre la Vista Hoja de datos, consiste en introducir directamente los datos en la tabla y según el valor que introduzcamos en la columna determinará el tipo de datos que tiene la columna.

Vista diseño es el método que detallaremos en esta unidad didáctica

Plantillas de tabla crea una tabla de entre un listado que tiene predefinido, abre una tabla de este tipo y sólo tendrás que rellenarla con sus datos.

Listas de SharePoint consiste en crear un objeto compatible con un sitio SharePoint desde el que podrás compartir los datos almacenados en la lista o tabla con otras personans con acceso al mismo sitio.



Explicaremos a continuación la forma de crear una tabla en vista diseño. Este método consiste en definir la estructura de la tabla, es decir, definir las distintas columnas que esta tendrá y otras consideraciones como claves, etc...

Otra forma rápida de llegar a la vista Diseño es seleccionando la vista desde la pestaña Hoja de datos, o haciendo clic en el botón de Vista de Diseño en la barra de estado:

A vista de Diseño

Aparecerá la vista de Diseño de la tabla:

Vista Diseño

En la pestaña tenemos el nombre de la tabla (como todavía no hemos asignado un nombre a la tabla, Access le ha asignado un nombre por defecto Tabla1).

A continuación tenemos la rejilla donde definiremos las columnas que componen la tabla, se utiliza una línea para cada columna, así en la primera línea (fila) de la rejilla definiremos la primera columna de la tabla y así sucesivamente.

En la parte inferior tenemos a la izquierda dos pestañas (General y Búsqueda) para definir propiedades del campo es decir características adicionales de la columna que estamos definiendo.

Y a la derecha tenemos un recuadro con un texto que nos da algún tipo de ayuda sobre lo que tenemos que hacer, por ejemplo en este nomento el cursor se encuentra en la primera fila de la rejilla en la columna Nombre del campo y en el recuadro inferior derecho Access nos indica que el nombre de un campo puede tener hasta 64 caracteres.